Subscribed unsubscribe Subscribe Subscribe

久しぶりにnodeを触るのでnodeとnpmとインストール済みパッケージをupdateしてみる

nodeとnpmをupdate

https://nodejs.org/en/
ここからインストールすれば、最新になる。

アンインストールして、再インストール等はしなくても問題ない。

※以下のエラーが出ている場合も同様

module.js:338
throw err;
^

Error: Cannot find module 'readable-stream'

ちなみに現時点だと

$ node -v
v5.9.0
$ npm -v
3.8.3

古くなっているパッケージを確認する

npm outdated

すでにインストールしていたパッケージをすべて最新化

npm update -g

以下のようなログが出れば完了。

✔ Global configuration file is valid
✔ NODE_PATH matches the npm root
✔ Node.js version
✔ No .bowerrc file in home directory
✔ No .yo-rc.json file in home directory
✔ npm version

Everything looks all right!

deprecatedのWARNをどうにかしたい場合

npm WARN deprecated graceful-fs@2.0.3: graceful-fs version 3 and before will fail on newer node releases. Please update to graceful-fs@^4.0.0 as soon as possible.
npm WARN deprecated lodash-node@2.4.1: This package has been discontinued in favor of lodash@^4.0.0.
npm WARN deprecated lodash-node@3.10.2: This package has been discontinued in favor of lodash@^4.0.0.
npm WARN deprecated graceful-fs@3.0.8: graceful-fs version 3 and before will fail on newer node releases. Please update to graceful-fs@^4.0.0 as soon as possible.

パッケージのリポジトリに対して、プルリクを作成するか、待つ。